Jump to content
  • Sign Up
KayTheCreator

Closed If you're experiencing the EAC Authentication Issue, Click here.

Recommended Posts

Hey there!

The issue is without a doubt very annoying, but its very treatable. (And will be fixed soon)

Unfortunately, there is no way right now you can 100% avoid running into it, but you can still get into the server following these steps.

  1. Launch the game from CGS Game Launcher, or using the Rust.exe (With launcher opened)
  2. When you encounter the "EAC: Client Authentication Failed" error, proceed with next step
  3. Open console - > Paste "connect 37.187.129.81:28241" (Without Quotes)
  4. Repeat this process over and over again until you finally load into server. (Can take up to four times)

Basically whats happening is while you are loading into the server, some type of EAC Hiccup interrupts the loading process during a specific stage. But if you repeatedly connect to the server, eventually all assets will be loaded into the memory and you'll arrive at the "Receiving Data" prompt, and eventually you'll be in-game.

Cheers

Edited by KayTheCreator
  • Upvote 6

Share this post


Link to post
Share on other sites
8 hours ago, thx4theshekelsgoy1 said:

look at this brown noser here fking kay :pig2: open that prettie mouth boy :kiss: lol (No Homo on my part )

you're a little bit much sometimes arent you goy lol

On 10/18/2017 at 8:43 PM, RennanRegis said:

This work me too . thx man ! :vogel:

On 10/18/2017 at 4:04 AM, MockNugget said:

whow it work :) tnx my friend

On 10/18/2017 at 4:01 AM, MockNugget said:

Might as well try it:)

Happy to help!

  • Upvote 2

Share this post


Link to post
Share on other sites

I can connect to the Vanilla server, but I can't get into the Modded server. It keeps giving me the EAC error. I've tried 10 times in a row now and can't get in.

I go to try the Vanilla server and it logs right in. Weird, right?

Any new suggestions to try for the Modded server? I don't think I've ever logged into that server, to be honest. (I'm a noob)

Share this post


Link to post
Share on other sites

its not working for me :( I playd it last night and in the morning I got the same problem its on the vanila srw
client.connect rust2.knights-table.net:28241
my ingame name ultimatevoider

and my eac is saying I need to repair it all the time still no awnser to my topick :(

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

By using this site, you agree to our Terms of Use.