Jump to content
VsUK

Closed Disable Server Auth?

Recommended Posts

Is there any way of disabling steam server auth on rust servers? I own the game along with 80+ of my friends & family members. However, were sick to death of the rust updates that force wipe the servers when we have to update to play. And because there's no way of stopping rust from updating to play. I'm wanting to use this rust client you guys provide a download link to, to connect to my own private server that I host on a server system at my home. However, I have tried server.secure false but no luck. Every time I try to connect it kicks me.

How on earth do you disable server auth so cracked clients can connect? Because thats the only need I have for a cracked client. Just to play the same version without being forced to update & wipe.

Share this post


Link to post
Share on other sites
13 hours ago, KahunaElGrande said:

Ty. I have managed to crack the server I want to host for private gameplay. It loads up fine. However. I had to install the server files using Rust Server manager. I did this. But apparently the client I downloaded from here is an older version from the server & just sticks on negotiating connection & does nothing else. 

Share this post


Link to post
Share on other sites

Just checked on the server when I try to connect. I set it to local 0.0.0.0 & the client detects it & when I connect, it sticks on negotiating connection. Then I get kicked off saying authentication timed out. On the server side. I get this EAC: Authentication timed out (1/2). 

 

Share this post


Link to post
Share on other sites

Sorry for the multiple posts btw. I can't edit the posts.  

But I resolved this by disabling VAC & other security using server variables. Now I get this when I conenct

disconnecting: NullReferenceException: Object reference not set to an instance of an object
EAC.Decrypt (Network.Connection connection, System.IO.MemoryStream src, System.Int32 srcOffset, System.IO.MemoryStream dst, System.Int32 dstOffset) (at <abb9fd0b13024eb5a06120c6a31a92c8>:0)                              93b/s in, 101b/s out
NetworkCryptographyClient.DecryptionHandler (Network.Connection connection, System.IO.MemoryStream src, System.Int32 srcOffset, System.IO.MemoryStream dst, System.Int32 dstOffset) (at <abb9fd0b13024eb5a06120c6a31a92c8>:0)
NetworkCryptography.Decrypt (Network.Connection connection, System.IO.MemoryStream stream, System.Int32 offset) (at <abb9fd0b13024eb5a06120c6a31a92c8>:0)
Facepunch.Network.Raknet.StreamRead.Start (Network.Connection connection) (at <17f9437afc7e44008d69a2da86c10dee>:0)
Facepunch.Network.Raknet.Client.HandleMessage () (at <17f9437afc7e44008d69a2da86c10dee>:0)
Facepunch.Network.Raknet.Client.Cycle () (at <17f9437afc7e44008d69a2da86c10dee>:0)
Client.Update () (at <abb9fd0b13024eb5a06120c6a31a92c8>:0)



I think its because the client is out of date to that of the server. And because you have to install the server files given.  You can't select the server version you want. I don't know what to do. Game client downloaded from here is older than the server. 

Share this post


Link to post
Share on other sites

The steps I took exactly. I started fresh to avoid contamination from other settings & so on. 

  1. I downloaded the RSM. I set my IP to the Hamachi IP.
    I used this method playing on legitimate servers with my purchased Rust client without problems. 
  2. I then downloaded Steam CMD, then downloaded the sever files. Main (Recommended).
  3. I then added these server variables.
    server.secure=False
    Valve Anti Cheat=False
    Easy Anti Cheat=False
    Anti Hack=False
  4. Opened up dnSpy & opened up the file Assembly-CSharp.dll in the directory specified
    Followed the instructions exactly, changing the ID to 480u from the previous one & then saved All, overwriting the original.
  5. Started the server & showed the following.
    Facepunch.Steamworks Unity: WindowsPlayer
    Facepunch.Steamworks Os: Windows
    Facepunch.Steamworks Arch: x64
    Setting breakpad minidump AppID = 480
    Connected to Steam
    eac_server.dll [x64] :: hModule: 00007FFDDBB10000 dwReason: 1 lpvReserved: 0
    Server startup complete.
  6. I already have rust installed by steam. But I have the downloaded Knights Table Rust v2108 Bandit town update & put it in a directory of its own. 
  7. I open up RustClient.exe. 
    Game load into the menu normally & displayed the server I started up from history when I tried this before starting afresh again. 
    I changed server name & description but keeping the IP to be sure the game see's my server correctly & it does.
  8. I click on server & click join. GameManager Warmup shows. Then a few seconds later, I get the following error.
     disconnecting: NullReferenceException: Object reference not set to an instance of an object
    EAC.Decrypt (Network.Connection connection, System.IO.MemoryStream src, System.Int32 srcOffset, System.IO.MemoryStream dst, System.Int32 dstOffset) (at <abb9fd0b13024eb5a06120c6a31a92c8>:0)                             107b/s in, 151b/s out
    NetworkCryptographyClient.DecryptionHandler (Network.Connection connection, System.IO.MemoryStream src, System.Int32 srcOffset, System.IO.MemoryStream dst, System.Int32 dstOffset) (at <abb9fd0b13024eb5a06120c6a31a92c8>:0)
    NetworkCryptography.Decrypt (Network.Connection connection, System.IO.MemoryStream stream, System.Int32 offset) (at <abb9fd0b13024eb5a06120c6a31a92c8>:0)
    Facepunch.Network.Raknet.StreamRead.Start (Network.Connection connection) (at <17f9437afc7e44008d69a2da86c10dee>:0)
    Facepunch.Network.Raknet.Client.HandleMessage () (at <17f9437afc7e44008d69a2da86c10dee>:0)
    Facepunch.Network.Raknet.Client.Cycle () (at <17f9437afc7e44008d69a2da86c10dee>:0)
    Client.Update () (at <abb9fd0b13024eb5a06120c6a31a92c8>:0)
    
    Version: 27971
  9. The Log.EAC file showed this
     
    14/08/2018 15:21:40  [Info] [SetLogCallback] Procedure: 0000027333BCB970 LogLevel: Verbose.
    14/08/2018 15:21:40  [Info] [Initialize] ServerName: 'Wagstaff'.
    14/08/2018 15:21:40  [Error] [Cerberus] [LogEvent] BeginFrame has not been called!
    14/08/2018 15:23:40  [Info] [Cerberus] [Backend] Connection established.
    14/08/2018 15:25:40  [Info] [Cerberus] [Backend] Disconnected.
    14/08/2018 15:26:54  [Info] [RegisterClient] Client: 0000000000000001 PlayerGUID: (Censored) PlayerIP: (Censored) OwnerGUID: (Censored) PlayerName: (Censored)
    14/08/2018 15:26:54  [Info] [UnregisterClient] Client: 0000000000000001 PlayerGUID: (Censored)
    14/08/2018 15:26:54  [Info] [Cerberus] [Backend] Connection established.
    14/08/2018 15:26:54  [Info] [Cerberus] [Backend] Disconnected.


    I don't know what I am missing or doing wrong. I followed the details exactly. However, it shows 9 modded servers in the client & I am able to connect to those servers without error. It just wont connect to my server. 

    Thanks in advance!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.